And another long time Hongfire member says hello

Status
Not open for further replies.

MiniMax

New member
Nov 8, 2013
15
38
Hi all,
glad to find a place with some well known faces from Hongfire.

I'm currently on a mission to add Oculus Rift support to many Illusion games released in the last years.

The current version supports PPD Studio Pro and Love Girl and my goal is to have added support to all Illusion games that I think are worth it when the Rift consumer version will be released.

Hope to meet all the talented HF modders here again...
 
ASF-teamへようこそ, MiniMax!

The ASF-community let you welcome in your new home, have lot fun with your beloved stuff/section here and of course with us, too. If you about what a or some more question(s) have, then let you not hinder come then to us, and we'll it explain, okay...?
 
[...]
I'm currently on a mission to add Oculus Rift support to many Illusion games released in the last years.
[...]

Hello MiniMax, and thank you for your awesome mod!
It really is the best adult vr experience you can get for now.


However, I have a big fps problem with it, I don't know if this is the best place to discuss it, but i don't think the IW mod discussion is the right place either.

With your mod activated I only get 30% of the fps I would get just with Tridef.
For example in this scene dl.illusion.jp/premium/scene_upload/download.php/security/co0006908/products_id/6908/cPath/26
with only a background and one person I get 57-59 fps in Tridef but only ~20 fps with Illusion VR activated.
In most scenes fps are arround 12-15 fps with Illusion VR, which is way too low.

I used your modiefied launcher and your Tridef profile.
Tridef is the neweset version.

Another funny thing about Tridef is, that I get arround 40% more fps if I set 720p in the PSP launcher instead of 800p.
So allowing 16:9 resolutions may be a way to get better performance.

My settings:
800p (1050P or 1200p run with the same fps)
Render Method 2 (Type 1 doesn't seem to ultilize the graphics card properly)
HW Vertex Proceccing (without the gc isn't ultilized)
Bilinear Filtering (just increases the gc activity, no impact on fps)
Texture Filtering (just increases the gc activity, no impact on fps)
MipMap Normal
Disable Hair Shadow


System Specs:
i5 3570k@ 4,2GHZ
Radeon 7950 @ 950 MHz
8 GB RAM
Win 8/8.1 (just upgraded to 8.1)


Workload CPU and graphics card:
CPU:
One core is at 100%, the other three at 15-20%
GC:
Depending on options and resolution activity is between 30% and 45%
(both withy render type 2 and hw vertex processing, without it is way lower)

Yeah, Illusion doesn't really care about optimizing their games. :rolleyes:



Am I doing something wrong? Is there a way to fix this, or is the fps hit to be expected?
If you need any additional information just ask me.
 
Hi jornte,
of course Illusion VR should have no impact on the frame rate. TriDef driver itself does because of the stereoscopic rendering and additional disortion for the Oculus Rift.

It really is the best adult vr experience you can get for now.
With only 12 fps you really didn't get a good experience at all. The fun starts with 30fps and is amazing with 45-60fps.


Just a few questions to make things clear:

- You mean 57-59 fps with TriDef running in Oculus Rift mode (with stereoscopic disorted side-by-side output active?
- When does the framerate drop that dramatically, after Illusion VR is started or after aligning the output to the Rift display?
- If you bind Illusion VR to another CPU core than the game (via Taskmanager "Set Affinity" option in Processes tab), does this make a difference?
- Do you have Win8.1 32bit or 64bit?
 
Last edited:
Thank you for your quick reply.

With only 12 fps you really didn't get a good experience at all. The fun starts with 30fps and is amazing with 45-60fps.
Of course, but even with 20 fps the potential is showing. :)

- You mean 57-59 fps with TriDef running in Oculus Rift mode (with stereoscopic disorted side-by-side output active?
Yes, of course.

- When does the framerate drop that dramatically, after Illusion VR is started or after aligning the output to the Rift display?
I start Illusion VR, start PSP with Tridef Ignition and the fps is already low. Linking the Rift or moving the game to the Rift doesn't affect the fps.
If I quit Illusion VR while still running PSP the fps recover, I get the fps I would get normally with just Tridef.

- If you bind Illusion VR to another CPU core than the game (via Taskmanager "Set Affinity" option in Processes tab), does this make a difference?
Just tried it. I bound PSP to two cores and Illusion VR and Tridef to one remaining each. No change. After that I moved Tridef and Illusion VR to the same PSP free core,
again without any change.

- Do you have Win8.1 32bit or 64bit?
64 Bit


I also tried different USB ports (2.0 and 3.0) with no results.


Edit: Some additional information:
I use the newest Radeon beta driver, on windows 8 I had the latest non beta driver.
Tried it without virus scanner protection (and changed the scanner after installing win 8.1)
Tried running Illusion VR with elevated rights.

Edit2:
Even if I use Illusion VR without having the Rift connected I get fps loss.
Fps went down on one scene from 36 to 19.
 
Last edited:
I did some further testing and found something that might help finding the problem:

I have 3 displays and the Rift connected to my graphics card.
2 displays over Display Port, 1 over HDMI and the Rift over DVI.
If I manually disconnect both DP cables (just disconnecting in Windows doesn't change the fps)
I suddenly get 37 instead of 17 fps in this scene:
For example in this scene dl.illusion.jp/premium/scene_upload/download.php/security/co0006908/products_id/6908/cPath/26
with only a background and one person I get 57-59 fps in Tridef but only ~20 fps with Illusion VR activated.

This is stiff a far way of of 57 fps, but might be an indication to you what went wrong.


Aside from that I tried Windows 7 32 Bit on another disk in the same pc and that didn't change anything.
So the problem doesn't seem to be specific to Win 8 and 8.1 or 64 bit systems.
 
Hi jornte,
I currently don't have a clue what goes wrong on your system. I own a nVidia card so it could be possible that this is an AMD specific problem, but I don't believe this. IllusionVR actually does nothing with the graphic, it just needs CPU time and uses Write/ReadProcessMemory to access the camera data of the game process. Probably I will build a test version with some Illusion VR functions disabled (and give you the link to test) to get an idea what might cause that fps drop.

If another AMD graphic card user could check if he suffers from the same problem that would help too.
 
I am happy to test for you.

If you could give me access to your source code I could try out a few things myself (I am a programmer myself).
Totally understandable if you won't though.
 
Hi jornte,
Sorry, I do not want to give the source code away at this time, maybe I'll change my mind later.

But I made a test version for you (for link see my PM). It allows to change the update rate of the camera data. Most (matrix/float) calculations and the process memory access are made in a multimedia timer (for best possible time accuracy) with a default delay of 2ms. This works absolutely fine on my system without causing any frame drop, but I have a fairly high end system and maybe that rate is a bit over the top for slower systems.

The test version allows you to change the MM timer rate. The IllusionVR.ini file, that is automatically created on first IllusionVR exit in the IllusionVR.exe folder now has a new parameter "UpdateTimerDelay" in the Settings group that defaults to 2 (for 2 ms). You can change that value to higher values, e.g. 100 would mean 100ms delay that represents 10 updates of the camera data per second. This of course makes the head tracking very choppy. I found 20 ms is a still acceptable delay.

Please note that the motion acceleration/decceleration phases when pressing a motion key currently become longer with greater delay values. If this test shows some effect on your system this behavior may be corrected.
Also the GUI update and FOV adjustment may be affected for values above 100 ms. But for testing purposes you can do so.
 
I testet the modiefied version, the effect was quite visible, but sadly no change in the fps.
I tested with 1,2,20,100,1000 and the fps stayed the same.

After that I did some testing regarding my graphics output configuration. There are noticeable differnences depending on what outputs I used:

(The HDMI display is 1200p, the others 1080p)
DP = (mini)Display Port

Testing without Rift, just monitors
DP 60 FPS
HDMI 60 FPS
HDMI + DP 57 FPS
HDMI + DVI 57 FPS
HDMI + DVI + DP 32 FPS
HDMI + DP + DP 36 FPS

So, just with one monitor there is no fps drop at all.

Rift connected to DVI
DP 45 FPS
DMHI 40 FPS (this is the worst result with connected Rift)

Rift connected to DP
DP 49 FPS (this is the best result with connected Rift)
DVI 47 FPS
HDMI 44 FPS

Rift connected to HDMI
DP 41 FPS
DVI 41 FPS


The FPS with only Tridef running are not affected by my display configuration.
A blind guess would be that it has something to do with how Illussion VR is reading (some kind of) information regarding the displays
or the the place something is on the desktop coordinates.
 
Hi jornte,
thank you for your testing and feedback.
I will review my code regarding multi monitor handling and check if there are any cyclic calls regarding monitor configuration that may be expensive on your system.

Just one more question:
- If you start PSP with an unsupported laucher (e.g. the Japanese launcher V1.3) so that Illusion VR does not detect the game (or reports "unsupported launcher"), is there still the frame drop or does it only happen if Illusion VR detects the game?

My application uses the Rift SDK and probably the "Is Rift still connected" call, which is performed cyclically may cause the problem.
I will probably build another version that does no cyclic checks regarding Rift display /Rift headtracker connection to see if that changes anything for you.
 
Tried with unsupported launcher, and still the fps went down.

But accidently I connected my Rif but forgot to plug in the USB cable.
I didn't notice this at first but was wondering why my fps in tridef were so low (20 fps instead of 60).
After I plugged in the USB cable I had 60 fps again.
So I started IllusionVR and disabled headtracking in Tridef. After that I had no fps drop anymore.
I guess with Illusion VR grabbing the trqacker output Tridef doesn't get any data from the rift and is doing something very ressource hungry to find the tracker.
Is headtracking disabled in Tridef on your system?
I don't know if headtracking off/on is saved in Tridef profiles, but I imported your profiles and headtracking was activated.
And I still don't get why my display confirguration had an impact on the fps. But I guess this is on Tridef then.

Anyway, thank you very much for your work and support.

The only problem I have left ist poor performance as soon as there are multiple charakters in the scene, but this seems to be due to bad optimizing from Illusion and
there is nothing to be done about it.
 
Hi jornte,
glad that you found the cause of the problem. Of course head tracking in TriDef must be switched off because Illusion VR aquires the Rift head tracker. My TriDef profiles have head tracking disabled and I was assuming that with the profile import this settings are also set correctly.

That makes we wonder what else of my original settings may not be correctly exported/imported with my TriDef profiles.
I will post my original settings here shortly. Would you be so kind to compare them with the settings that you have after importing my profile and report any difference?

This may help me to update my installation guide with essential information regarding the import that may help other to to avoid this problem.
 
Last edited:
So here are all the settings I did in the TriDef OSD for PDD Studio Pro before exporting the profile:

TriDef Settings.jpg

Could you compare these settings with yours after the PPD Studio Pro TriDef Profile import.
Is the "Profile" submenu available for you in the TriDef OSD?
 
Welcome Minimax, it is a very interesting discussion going on here I think, looks like we'll see more things rather than just more spam going on in ASF :P Joking aside, it is lovely to see more people joining ASF and hopefully you'll enjoy your time here with us. I think maybe you should share the love in the Tech Support/Talk section where maybe even more people might join in the discussions (since I know there are a few active tech support/talk lurkers that doesn't really drop by Introduction too much) so you can share this interesting conversation with others. I hope to see you around and have a fun time staying here ;) If you do need any assistance then please feel free to contact me or a member of staff and we'll get back to you ;) See you around~
 
Hi KingArturia,
thanks for welcome.

Hi jornte,
I'm still waiting for your answer.
It is fine that you have solved the problem but like I have helped you it would be nice if you also would help others.
 
Last edited by a moderator:
Just a friendly reminder, we do not promote double posting~ Please refrain from doing so in the future, thanks~
 
Hi MiniMax,

sorry I had no time yesterday.
But I found another source of fps drop, not related to Tridef or Illusion VR nut the HF patch:
The option to run in windowed fullscreen cuts fps in half.
It might be worth to mention that Illusion VR users shpuld not install this or if they have installed it delete the dll in their PSP directory.

I tested 2 ways: first I made sure that every of my settings differ from your, saved the profile and
after that I took a fresh profile from you and checked the remaining differences. For the second test I deleted PSP from Ignition, readded it and used your pofile from the start.

All options different

3D
everything different

Performance
everything different

Laser Sight
everything different

Outpout
Output different
Swap L/R different

3D Object Detection
Row Major Matrix different

HMD-Settings
everything different

New PSP in ignition

3D
Scene depth different

Performance
3D texture copy different

HMD Settings
everything but

OSD on HMD
Additional Res

different.


-------------------

Hope that helps.

Two quick points:
Shouldn't 3D Texture Copy be faster?
Isn't World Scale the parameter to be used and not Scene Depth?
 
Hi jornte,
thank you for your valuable feedback. I was under the impression that a TriDef profile contains all the settings that I made in the TriDef OSD for a game. But how it looks only the settings in the "Profile" menu are actually part of the TriDef profile. (that's probably the reason why it is called profile).

That of course does means that my installation guide is incomplete and all the guys trying IllsuionVR had totally wrong settings initially. Even the most important settings in the HMD menu (World Scale, Output FOV and Head Tracking) are totally wrong.

Since my complete game settings must be stored somewhere, I will try to figure out at which location that is (most probably the registry) and provide that settings (additional to the profile).
Also I will add a table to my installation guide with the required settings for each supported game for reference.

You should set all the TriDef settings for PPD Studio Pro to the values in the screenshot of my previous post to get the experience as it was meant to be.


Shouldn't 3D Texture Copy be faster?
Don't know, but will research.

Isn't World Scale the parameter to be used and not Scene Depth?
That's right. In Oculus Rift mode many of the parameters outside of the HMD menu don't have a meaning.
I just added all values to avoid questions about the missing parameters.

The option to run in windowed fullscreen cuts fps in half.
It might be worth to mention that Illusion VR users shpuld not install this or if they have installed it delete the dll in their PSP directory.
Thanks for that hint. Will notice that too in my guide.
I had also experiemented with code to remove the game window caption/frame and found exact the same problem (half the frame rate). Also when I align the game window exactly to the Rift screen (so that the caption is off-screen), the effect is showing.
Very strange, my solution was to slightly shift the window down on the Rift screen so that a certain amount of the caption bar is on the Rift display. (You don't actually see this in the Rift as the edges of the screen are not visible.)
 
Last edited:
Hmm... Sorry guys, I don't want than spoilsport act now, but I've it say, that this actually to the Tech Support and Talk section belong, what you lead...:goodtea:~>
 
Status
Not open for further replies.

Users who are viewing this thread

Latest profile posts

Ver wrote on girlcelly's profile.
Hello, I was wondering if you can reupload or reseed 戦極姫3~天下を切り裂く光と影~ 遊戯強化版-壱ノ巻?
nobis_c wrote on Otokonoko's profile.
Btw Otokonoko, do you have the latest version of this game? It was long overdue for an update.
UnHolY JaiL TRPG to Ver.2024.06.02 / Ver.1.20