[Uncensor] SBX2.5c Uncensor for use with Uncensor2 Framework

Belgar17

Member
Elite Member
Sep 11, 2016
174
274
SBX2.5c Uncensor for use with Uncensor2 Framework

SBX2.5c Uncensor version created specifically to work with Vrl0ver's Uncensor2 framework/models v0.0.4 mod.

When used with the Uncensor2 Framework, this mod display the SBX2.5c mesh in clothing's tops which were not made originally with this uncensor, requiring no modifications or editing to the original top's file.

For example, in the included picture, the top section shows a female character with a shirt which don't include any uncensor. The bottom section shows how the uncensor is added to the same shirt by just enabling this mod.
Uncensor2_SBX25c.jpg
Features:
1. Allow the use and display of the SBX2.5c Uncensor in clothing's tops mods originally made without a uncensor (vanilla) or with a different/older uncensor.
2. Do not require top's mod files to be edited or modified.
3. Works in all character dress states: Fully dressed, half dressed, fully undressed.
4. Can be used in the game and the studio.
5. Only affect selected characters.
6. Can be used, disable or removed without affecting the character looks.
Limitations:
1. Vrl0over's Uncensor2 Framework/models v0.0.4 must be already installed and working.
2. Since the Uncensor2 Framework is still under development, it may not work with all tops mods.
3. Pubic hair may not display correctly if the full SBX2.5 Uncensor is not installed in the system.
4. The mod requires the use of 1 accessory slot, reducing the number of available accessories that can be used.
5. Mod may not be compatible with older versions of Plasticmind's 4K mod.
6. Since mod use its own custom textures, there may be a small difference between the looks of female character when the mod is enable and when it is disable.
Install:
Copy all directories/files into the game main directory (Illusion/HoneySelect).
Note: Remember that the Uncensor 2 framework/ models v0.0.4 most already be installed properly.

Uninstall:
In directory Illusion/HoneySelect/abdata/chara/Uncensor2, delete files uc2acc_sbx2_5c.unity3d, uncensor2proto_sbx2_5c.unity3d, and subdirectory /sbx2_5c
In directory Illusion/HoneySelect/abdata/list/characustom, delete file uc2list_sbx2_5c.unity3d
In directory Illusion/Plugins/HSUncensor2, delete subdirectory /sbx2_5c
Note: Mod can be uninstalled without affecting any other Uncensor2 framework's mod already installed.

How To Use:
Adding to your character:
1. Open the game's Female Character Maker.
2. Open (or create) your female character.
3. Go to the Clothing menu.
4. Select one of the slots in the Accessories Section.
5. In Accessory's type, select Waist.
6. Select [UC2] SBX2.5c from the list.

To disable (hide):
1. In the game or studio, change the state of the accessory slot used to Hide.

To enable (show):
1. In the game or studio, change the state of the accessory slot used to Show.

To remove from your character:
1. Open your female character in the game's Female Character Maker.
2. Go to the Clothing menu.
3. In the Accessories Section, select the slot being used by the mod.
4. Change the accessory type to None or select a different accessory.

Uncensor Download: https://mega.nz/#!8pUTFA6R!FaPXAiT4SknZo6kHFrZCzgpZhNC8gPCeLg_qciOKsug

Uncensor2 Framework v0.0.4 can be found here: http://www.hongfire.com/forum/forum/hentai-lair/hf-modding-translation/honey-select-mods/5776685-uncensor2-new-framework-of-switchable-female-uncensors-prototype


Acknowledgements: Thanks to Stampar for all his hard work in continously maintaining and improving the SBX Uncensor. An a very large applause and thanks to Vrl0ver for creating his outstanding mod, which finally remove the limitation of using only one uncensor in the game.
 
awesome ,now i can use SBX2.5c with uncensore2, thank you very much for the update
 
Stinger722's Innie Uncensor
I have added a version of Stinger722's Innie Uncensor (as fixed by Stampar) which can be used with Vrl0ver's Uncensor2 Framework v0.6.0. since there has been several requests for it.
I had made no changes to the mesh so it has all the same clipping issues with panties, pantyhose, etc. as the original. It is offered "AS IT IS", meaning I will not make any changes or adjustment to it, not maintain it in the future. You can use it freely with these limitations.

Download: https://mega.nz/#!xgViXACS!QOyXNHdrrByJuhhF6CLXn7285qNc8MiQRye_ajDCuQk
 
  • Like
Reactions: eleven
For it to work with the new DLC you need to upgrade to Uncensor2 Framework V0.6.2. I don't have the link right now because HongFire is still down.

The Uncensor2 Framework have been updated again to V0.6.3. The link for updated version is on Pastebin. I will send you mod link.

[Update]
v0.6.3 (beta):
- Fixed bug: uncensored part remain visible in StudioNEO even when character visible option is turned off.
v0.6.2 (beta 4):
- (Internal) Added method for work with HSStudioInvisible v4.1 (Invisible Ring does not hide censored area)
v0.6.1 (beta 3):
- Support new HoneySelect DLC 2017/04/28, HoneySelect Party, HoneyStudio Neo.
v0.6.0 (beta 2):
- Better integration with SkinTexMod.
With IPA 3.0b+ and the additional plugin file "HSUncensor2SkinTexModAdapter.dll", SkinTexMod will work even when switching accessories.
- Fixed problem in HoneyStudio when "Default=" option is used.
- Fixed problem tattoo and sunburn texture does not correctly loaded when Uncensor2 accessory is disabled.
 
So which one on the Pastebin is the right one? I see HS_SBX2.5_Custom_Uncensor_v1.1 (updated April 15th) and then there is HS_Uncensor2_Prototype_v0.6.2 (updated April 29th) as well as HS_Sample_Uncensor2_MOD_Pack_v0.0.5 in the same section.

You have v0.6.3 listed as the latest version, but that version isn't on the pastebin that I can see. Highest version number on the pastebin is v0.6.2.

I want to make sure I install the correct one since it is really easy to screw the game since the last DLC update. I've already had to unfuck my install twice, trying to avoid fuck up #3.
 
So which one on the Pastebin is the right one? I see HS_SBX2.5_Custom_Uncensor_v1.1 (updated April 15th) and then there is HS_Uncensor2_Prototype_v0.6.2 (updated April 29th) as well as HS_Sample_Uncensor2_MOD_Pack_v0.0.5 in the same section.

You have v0.6.3 listed as the latest version, but that version isn't on the pastebin that I can see. Highest version number on the pastebin is v0.6.2.

I want to make sure I install the correct one since it is really easy to screw the game since the last DLC update. I've already had to unfuck my install twice, trying to avoid fuck up #3.

Let me try to make it more clear.

HS_SBX2.5_Custom_Uncensor_v1.1 is a special version made Stinger722 with have a innie style vagina with a camel toe. It only worked with the full naked body, it didn't change any of the clothed files so you need another uncensor for that.

HS_Uncensor2 is a mod which allows different uncensors to be installed and used without needed to change any body or top file. It swap the vagina mesh of the character with a different uncensor mesh while the game is running. So no matter which default uncensor is installed for the body and the clothes, you can display a different one in your character.

For HS_Uncensor2 to work you need 2 things. The first is the framework which is the plugin that make all the changes dynamically as the game is running. The second is the uncensors meshes mods that the framework will use and display. The files in this post are 2 different uncensor meshes to be used with the framework. There is also a set of other uncensor meshes called Sample_Uncensor2_MOD_pack_v0.5.0 that can be found here Pastebin.

The framework version in the Pastebin, V0.6.2, will work with the new DLC and studioneo but it has a few bugs that were corrected in V0.6.3, which is the latest I know off. This is the link I had for it: https://mega.nz/#!MEZSAYRZ!_vpikW_8-hBxm1_BVYOWJGSemIfr9lsbO3RXk-XAeS8

Hope this help. Sorry if I'm explaining things you already now.
 
  • Like
Reactions: Grimraven
Thanks a bunch for taking the time to explain. I've been using the SBX2 uncensor pretty much the entire time I've had the game installed. To be honest, that was the uncensor I had been looking for. I'm assuming that it has been discontinued and I'll need to switch over to the HS_Uncensor?
 
Thanks a bunch for taking the time to explain. I've been using the SBX2 uncensor pretty much the entire time I've had the game installed. To be honest, that was the uncensor I had been looking for. I'm assuming that it has been discontinued and I'll need to switch over to the HS_Uncensor?

No, the regular SBX uncensor is still available and can still be used. For the moment there is no plan to discontinue it. The current version is 2.5c and the new DLC tops has been changed to it as well. If you are happy with SBX you can continue using it. You can find it in its own post here: http://www.anime-sharing.com/forum/requests-releases-honey-select-mods-143/uncensor-sbx2-uncensor-full-release-546816/

With the regular uncensor you had to use the same uncensor for all the characters and modders making clothing had to decide for which uncensor to make them. The HSUncensor2 Framework on the other hand make it possible to have different characters with different uncensors, even at the same time. Also it allows to show any uncensor with any clothing you want, even if the clothing was made without one.

HSUncensor2 is still been developed and like any other mod there as still limitations, trade offs and issues to be resolved but in general it works amazingly well. The idea of HSUncensor2 is just to provide more variety and flexibility.
 
  • Like
Reactions: Grimraven
No, the regular SBX uncensor is still available and can still be used. For the moment there is no plan to discontinue it. The current version is 2.5c and the new DLC tops has been changed to it as well. If you are happy with SBX you can continue using it. You can find it in its own post here: http://www.anime-sharing.com/forum/requests-releases-honey-select-mods-143/uncensor-sbx2-uncensor-full-release-546816/

With the regular uncensor you had to use the same uncensor for all the characters and modders making clothing had to decide for which uncensor to make them. The HSUncensor2 Framework on the other hand make it possible to have different characters with different uncensors, even at the same time. Also it allows to show any uncensor with any clothing you want, even if the clothing was made without one.

HSUncensor2 is still been developed and like any other mod there as still limitations, trade offs and issues to be resolved but in general it works amazingly well. The idea of HSUncensor2 is just to provide more variety and flexibility.

Again, thank you very much for taking the time to reply and provide information.
 
@Belgar

The worst visual problem I have encountered is the strong reduction of Custom Juice Texture (v2.5c), over Aoyu18 unc in Game and Studio


Comparison:

SBX2.5c (skin Type 4) 100% Full Cum
NA8X5m7K.png


Aoyu18 Unc (skin Type 4) 100% Full Cum
CvEplloB.png



How can I fix it?
 
@Belgar

The worst visual problem I have encountered is the strong reduction of Custom Juice Texture (v2.5c), over Aoyu18 unc in Game and Studio

How can I fix it?

HSUncensor2 aoyu18 is set to use it own set of juice texture. You can set it so it will use the default juice textures instead.

To do this, the configuration file for the HSUncensor2 aoyu18 have to be edited:

Go to directory Illusion/HoneySelect/Plugins/HSUncensor2/Aoyu18
Open file Aoyu18.cfg (this is a text file so you can use Notepad for editing)
Locate the following line: AB_sirutex=abdata/chara/uncensor2/aoyu18/sirutex_aoyu18.unity3d
Change the line to read: #AB_sirutex=abdata/chara/uncensor2/aoyu18/sirutex_aoyu18.unity3d (the # make the line a comment so it wouldn't be read)
Save the changes
 
Why is this happening???  SBX2.5c installed with pubic hair patch and custom juices.  Using Uncensor2 with Aoyu18 as default.  4K Diffuse Pack test version 5-3-17.
 
 
Why is this happening???  SBX2.5c installed with pubic hair patch and custom juices.  Using Uncensor2 with Aoyu18 as default.  4K Diffuse Pack test version 5-3-17.
 
That is happening because in Uncensor2 Aoyu18 the pubic hair mesh used do not completely match the uncensor mesh and the panties mesh, so there are some clipping. The Vanilla and the Aoyu18 was put in the Uncensor2 just as samples to demonstrate the mod so they still have some flaws.
 
That is happening because in Uncensor2 Aoyu18 the pubic hair mesh used do not completely match the uncensor mesh and the panties mesh, so there are some clipping. The Vanilla and the Aoyu18 was put in the Uncensor2 just as samples to demonstrate the mod so they still have some flaws.
Damn. I thought the Uncensor2 finally working like I want. Now I am wrong. It happen with most panties but not all. This is only problem with Aoyu18 until can be fix.
 
That is happening because in Uncensor2 Aoyu18 the pubic hair mesh used do not completely match the uncensor mesh and the panties mesh, so there are some clipping. The Vanilla and the Aoyu18 was put in the Uncensor2 just as samples to demonstrate the mod so they still have some flaws.

Hi I want to start by thanking you for doing this, It's a great mod. Hilite? has this uncensor on their page http://hilite000.blog.fc2.com/blog-entry-136.html which is great, but I'd prefer a version that works in this system. I've poked around with the files you've provided for the other plug-ins so to speak but I don't understand how to do it myself. So far as I can tell Hilite seems to have given permission to use it for other things granted acknowledgement so I'm curious if you or someone on here minds adapting that uncensor to this system? or is it a big chore to do?
 
Hi guys .. I have a problem ...

I have SBX2 uncencor
4K diffuse initial pack .
Latest Graphic patch ...
All DLCS .

But none of Game's lipstisck..and cheek makeups maybe more that i did not try yet ..Not working :( ..
What can be the reason? Or how can i fix it ?
 
Hi guys .. I have a problem ...

I have SBX2 uncencor
4K diffuse initial pack .
Latest Graphic patch ...
All DLCS .

But none of Game's lipstisck..and cheek makeups maybe more that i did not try yet ..Not working :( ..
What can be the reason? Or how can i fix it ?
You most probably cause is the version of the 4K Diffuse mod that you are using. The early version required that other skin related items( like tattoos, eyeshadows, etc.) also be in 4K or they wouldn't work properly. You should check the latest version of the mod which I believe corrected this issue.
 
Great thanks Belgar i will check it ..
Should I update all or only 4K diffuse pack?

UPDATE : I checked I have 4K diffuse pack 12/04/2017 version already which is the latest on mega .. So no other updated version..
NOTE : last check.. Nothing in the games standard facial makeups working... :( no cheeks no lips no eyes..
My version of SBX is 2.5e
I found the latest graphic patch .. But saw noted on hongfire after new updates new graphic pact [ HSParty Graphic Patch ver.170619 ] it is not working ..

"A help on this will be appreciated really .. " I am tired of making new installs.

LATESTUPDATE :: Oh yes..I was brave cause i made a backup .. installing [ HSParty Graphic Patch ver.170619] fixed all problems ...
Now all of them works .. Just moles..i don't know why. But i won't use them anyway .
 
Last edited:

Users who are viewing this thread

Latest profile posts

LazuH1KKA wrote on Shine's profile.
GuRu wrote on Esan's profile.
https://www.anime-sharing.com/threads/200828-innocent-grey-虚ノ少女《new -cast-remaster-edition%E3%80%8B-%E3%83%91%E3%83%83%E3%82%B1%E3%83%BC%E3%82%B8%E7%89%88.1289457/を katefile または mexashare またはrosefileに再アップロードして頂けますか。
nanashinanashi wrote on Esan's profile.
can you please reupload https://www.anime-sharing.com/threads/111125-overdrive-d2b-vs-deardrops-cross-the-future.1174725/ to katefile or mexashare or rosefile.Thanks
Seiki wrote on Shine's profile.
Hi, could you please reupload this?
https://www.dlsite.com/maniax/work/=/product_id/RJ423317.html

a new ep is come but i need old ep (sorry for my eng skill)
thank you.