(delta) おねがい助けて!~外に出たらヤられちゃう~ can't run. serial code/ this product is only for inside of japan.

Gilgaduck

New member
Trusted Member
Apr 14, 2018
41
1
Hello was wondering if anyone could help me out here. I've downloaded おねがい助けて!~外に出たらヤられちゃう~ and am unable to run it, i've seen various people with the same issue i have but have yet to find a working solution for it.

I've downloaded it from

http://www.anime-sharing.com/forum/...]-[delta]-おねがい助けて-~外に出たらヤられちゃう~-patch-485258/

installed it + installed the patch

when i run it normally i get a serial code verfication.

If i run it using AlpharomDie i end up having a message saying this product is only for inside of japan.

I've tried ntlea, changing my system locale + system format to japan. The only thing i've yet to do is install a virtual box which i'd like to avoid if possible due to pc space.

Thank you hopefully someone can help me out.
 
yup i've tried that too. if i use it on the original game exe it just has the serial code pop up. if i use it with the alpharomdie game.exe it'll open up alpharom and if i drag the file in again on it it'll just have that this game is only for inside japan popup.
 
I'm CBA to download the game but do you know if this is Sigplus engine?

If it is, you would need No_Region_Loader_Sigplus
 
srry not sure which engine it is. i've tried no region loader sigmus just now but if i use it on the .exe game it'll just pop up the serial code page. Idk how to use a no region loader with the alpharomdie together or if there's another way to get past the serial code part.
 
sadly it still gives me the same result as alpharomdie. "this product is only for use inside japan" trying to use the patched exe with ntlea or no region loader still gives me the same pop up sadly.
 
Supposedly, Delta game had this for a while but both NTLEA and Locale Emulator was reported to work with them. I'm not sure why you're having the problem.

I know it's a dumb question but are you sure you Local Emulate the correct exe file (not the launcher, but the game executable itself) ?
 
np, and yup i've done it to the game.exe, just to be safe i tried it with the launcher.exe too but both give the same results. with this "game only for inside japan" if i use alpharomdie or no region loader, otherwise i get the serial code request.

I wonder if it's an issue exclusive to this game because from what i saw from other forum posts the sequel didn't have this issue, and ik i've ran some other games from delta fine before. I also can't find any type of crack for this game either.
 
Another vector is that If you can find a demo for that game, replace the original exe with the demo executable and try again perhaps?
 
np thanks for trying. figured it was prob a lost cause since there's no solutions on the forum for the game but figured i'd ask to see.
 
Hey a bit late but did you try using Ntleas from here https://archive.codeplex.com/?p=ntlea (not to be confused with Ntlea) ?
Also there are some games that give me a popup along those lines you described and if I just click OK/skip/whatever/close it will continue to run the game properly after a few seconds.
In any case, aside from the system locale, format and location, sometimes you also need to change the clock to tokyo timezone, and sometimes you even need to change the windows display language as well.

Note that there are cases where game cracks only work properly on an older system and the same can be said for newer cracks that only work properly on a newer system.
 
np thanks for trying. figured it was prob a lost cause since there's no solutions on the forum for the game but figured i'd ask to see.

Hey a bit late but did you try using Ntleas from here https://archive.codeplex.com/?p=ntlea (not to be confused with Ntlea) ?
Also there are some games that give me a popup along those lines you described and if I just click OK/skip/whatever/close it will continue to run the game properly after a few seconds.
In any case, aside from the system locale, format and location, sometimes you also need to change the clock to tokyo timezone, and sometimes you even need to change the windows display language as well.

Note that there are cases where game cracks only work properly on an older system and the same can be said for newer cracks that only work properly on a newer system.

----------Managed to make it work, check the end part

Just for future reference NTLEAS almost works.
When you get that error message the game generates a StartInfo.txt file kinda like this:
(without ntleas but windows japanese format and unicode)
Code:
rsysUILID:0x416
rsysLocID:0x411
rsysLCID:0x411
ruseUILID:0x416
ruseLocID:0x411
ruseLCID:0x411
hkl_low:0x416
rThrLCID:0x411
rOEMCP:932
rAnsiCP:932
_timezone:-32400

(with ntleas)
Code:
rsysUILID:0x411
rsysLocID:0x411
rsysLCID:0x411
ruseUILID:0x411
ruseLocID:0x411
ruseLCID:0x411
hkl_low:0x416
rThrLCID:0x411
rOEMCP:932
rAnsiCP:932
_timezone:-32400

For the game to run those first numbers needs to all be 0x411 but 'hkl_low' fails to set.....
Whatever thats checking for that's the reason why NTLEAS doesn't work.

From what I found out this "hkl_low" stands for the keyboard layout identifier. 411 is the japanese layout code.
I just don't know how to fake that or how the windows gets this.

Edit:
I've managed to make it work somehow.
You actually need to "change" the preferred windows language. This might be different depending on the windows update version but it should be similar to this https://www.asus.com/support/FAQ/1030002/
Basically on Settings->Region&Language you add a new language, Japanese.
Then you either set it as the default language or move to be the first. It'll only turn windows display lang japanese if you restart the pc, so DON'T.
Then you need to start the game with NTLEAS and it should work.

Just remember to set your old language back later when you're done playing because windows will use the default language when it starts up. So if your windows boots up japanese, thats why.

If that doesn't work, make sure in the options of the japanese language, the "Hardware keyboard layout" is set to Japanese Keyboard. I think thats the default.
 
Last edited:

Users who are viewing this thread