Bug Can't preview Thread Thumbnail

The Bomb

New member
Trusted Member
Feb 2, 2014
43
5
I used to be able to see/enlarge thread thumbnail by hovering it, but now I noticed it only show the detail of the thread rather than the thumbnail itself. Is it a bug? or you can't preview the thumbnail anymore? Thanks
 

Attachments

  • Untitled.png
    Untitled.png
    28.7 KB · Views: 197
I noticed this too. Hard to look at the small thumbnail.

Whether it gets fixed or not, hopefully v2 brings grid view.
 
Upvote 0
hello The Bomb, that is a bug but Checkmate is very busy for ASF v2, and I'm not sure that he can fix it soon.
 
Upvote 0
Damn just noticed this today, so hard to quickly scan through potential games for now, almost off-putting :(


attachment.php

p5d1n.jpg
 
Upvote 0
You can use the Zoom option in your browser in the meantime so you dont strain your eyes.
 
Upvote 0
You can also try a zoom extension for images. "Imagus" works. I added
"!:*
~://www.anime-sharing.com/" in the grants section so that the extension only works on A-S.
 
Upvote 0
I hope this will get fixed, cause this is like the best feature in a forum with this specific setting. ^^
 
Upvote 0
The problem is due to jQuery not being loaded which is aperent from errors in the developer console (F12). This is simple to resolve; but meanwhile you can run the following js-snippet from your chrome/firefox developer console (again F12 to open it) which will load jQuery 1.11.1 from the google CDN and re-init the image preview function.

Code:
const script = document.createElement("script");
script.src = "//ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js";
script.onload = function() { 
   imagePreview();
   setTimeout("removeTitle();", 1000);
};

const head = document.getElementsByTagName("head")[0];
head.appendChild(script);

Again this is just a work arround, if you don't know how to open developer console and run js from it don't use it. If you don't trust the snippet don't run it as well.
 
Upvote 0
Yeah, this isn't a bug. By default, browser will only load https resources (media/images) while on a https site.

I'm not going to put more band-aids on ASF v1 because it was never meant for https.
ASF v2, no doubt, is designed natively, and will only work with https.
 
  • Like
Reactions: Argetlams
Upvote 0
May be, but please don't change it, it is for your own security. Please be patient for ASF v2, it is within mere weeks.
 
Upvote 0
Yeah, this isn't a bug. By default, browser will only load https resources (media/images) while on a https site.

I'm not going to put more band-aids on ASF v1 because it was never meant for https.
ASF v2, no doubt, is designed natively, and will only work with https.

I beg to differ. Unless it was a conscious decision to not load jquery I would consider this a bug.

It has been an issue for atleast 6 months now. The root cause is the fact that the script to show popovers is using jquery (global $ variable) which is just not loaded. Apart from the fact that jquery is generally shunned upon these days for all sorts of reasons I don't see what http vs https has anything to do with this.

Just loading jquery from any CDN will instantly fix the issue, you don't even have to include the protocol prefix in the script source URL so it will work for both http and https.

Fixing it is quite literally a 5min job, include the latest jquery library from any CDN in the head tag of the template.
 
Upvote 0
I understand there's been a bit of confusion surrounding the recent issues on our forum. I'd like to clarify things a bit.

Our forum engine is designed to operate with a very specific version of jQuery, version 2.2.x. Loading the latest jQuery library from any CDN will invariably cause problems.

The forum engine is programmed to automatically load the necessary jQuery library where required. While it's possible to rewrite certain parts to enforce the use of jQuery, this wouldn't address the underlying issue.

Here's where the crux of the problem lies: Our website, originally developed with HTTP, was not designed to operate using HTTPS. This means that while some images will load correctly, many will not. The reason for this is that these image resources are directed towards the HTTP link. Modern browsers, in their attempt to be "smart," will automatically try to load these resources using HTTPS. However, not all image hosting websites support HTTPS, resulting in broken links.

Here's one example: see how the website is using an invalid cert. (Link may be NSFW, taken as an example straight off a page here)
https://6.t.imgbox.com/jPfo7IEU.jp

The release of ASF v2 is coming soon. It will solve this issue: a middle proxy will ensure that all resources load correctly, even if the original hosting site doesn't support HTTPS.

I want to focus our efforts on resolving the root cause of the problem rather than applying half-baked fixes. This approach might take a bit more time, but our goal is to provide a truly robust and seamless experience for all users.

We appreciate your understanding and patience as we work on these improvements. Stay tuned for further updates on our progress with ASF v2!
 
Upvote 0
I've been using Neos' fix and its working well. Not sure if there is any problem since it seeems like its not the intended version, but if you create a bookmarklet or use userscript manager its easy to run.

Hopefully grid view comes with v2 and we dont even have to hover over the images!
 
Upvote 0
Hopefully grid view comes with v2 and we dont even have to hover over the images!
Unfortunately, the initial release of v2 will not include the grid view feature. While the feature was considered, the complexity of integrating grid view with different forum views like when searching and viewing articles forum presented a considerable challenge. I made the decision to exclude it due to the substantial development resources it required relative to its scope. I hope to revisit this feature in the future.
 
Upvote 0

Users who are viewing this thread

Latest profile posts

NaquanH wrote on Shine's profile.
Hi Shine
Can you update this please? Content added Adult store and story recollections.
https://www.anime-sharing.com/threads/✨shine✨-240530-tomotostew-僕のメイド-rj01203511.1493234/

Thank you!
darkpachon wrote on Nihonjaki90's profile.
sorry, could you reload the links of [080229][Hakudakukei] 催淫術師~恥辱まみれの絶頂
GuRu wrote on Shine's profile.
こちらを再アップロードおねがいします、いつもありがとうございます 
xt.20111015 wrote on Nihonjaki90's profile.
こんにちは、@Nihonjaki90 さん。これを再アップロードしていただけますか? いつもありがとうございます。m(_ _)m